Das neue FRA-Spotterforum

Das alte FRA-Forum ist nicht mehr...


Technische Gründe und nicht zuletzt auch das recht hohe Alter der Software - der Hersteller bietet seit einigen Jahren keine Updates für diese Version mehr an - machten einen sicheren Weiterbetrieb nach dem Domainumzug nicht mehr möglich.

Der Anbieterwechsel an sich lief fast glatt ab: die Website ging ohne Aufwand auf den neuen Webspace und die Spottetouren-Seite wurde wegen vorhandener Einstellungen des alten Providers vorsorglich gelöscht. Der Aufwand, sie wieder neu aufzubauen ist vergleichsweise gering. Lediglich das Forum wollte nicht so recht.

Als es dann nach drei Tagen endlich auf dem neuen Server angekommen war, ließ es sich nicht aufrufen und folglich auch nicht testen. Da im letzten Jahr auch noch die Umstellung auf eine neuere PHP-Version das Forum kurz lahmlegte und ich eine saubere Installation beabsichtigte, beschloss ich, eine neue Forensoftware zu kaufen. Nachdem die neue Version installiert war, sollte jetzt die Datenbank importiert werden.


Das Chaos beginnt


Die meiste Zeit in den beiden letzten Wochen der Installation und des Datenbankimports verbrachte ich vom späten Nachmittag bis teilweise nach Mitternacht und nach kurzer Schlafpause am sehr frühen Morgen, bevor es zur Arbeit ging. Den ersten Versuch zur Datenübernahme startete ich gleich am ersten Abend. Doch nach einiger Zeit brach der Transfer mit einer Fehlermeldung ab, laut Übersetzung handelte es sich wohl um ein Problem mit der Struktur der DB und daraus resultierenden fehlerhaften Inhalten. Gut, dachte ich mir und suchte nach Wiederherstellungs- bzw. Datenrettungssoftware.

Jede dieser Software meldete einen anderen Fehler, aus denen ich mit der Zeit nicht mehr schlau wurde.


Eine - endlich - erfolgreich wiederhergestellte Datenbank ließ sich dann auch fehlerfrei importieren, war aber offenbar auch nicht komplett. Sie hatte zwar fast 200 Tabellen, aber nur ein Viertel der Daten vorrätig. Mit dieser Importversion gabs dann nach etwa 4 Minuten den ersten Crash. Dabei blieb es im Laufe der Woche nicht, denn ständig brach mir das Forum ab und ließ sich nicht mehr aufrufen. Mir blieb nur noch die Option einer Neuinstallation..


Nach zwei Tagen mit ständigen Abbrüchen und merkwürdigem Laufzeitverhalten beschloss ich, die Datenbank liegen zu lassen und mit einem nigel-nagel-neuen FRA-Forum durchzustarten, in dem es am Anfang nichts gab außer dem bunten Front-End für die User und einer leeren Datenbank.


Somit steht uns das FRA-Spotterforum seit heute wieder im neuen Layout zur Verfügung!


Geändert hat sich wesentliches, das meiste davon im Adminbereich. Für die User gibt es z.B. keinen Bedankomat mehr, sondern "Likes" und auch die Tapatalk-Unterstützung ist nicht mehr vorhanden. Da ich aus Erfahrung weiß, dass es am Anfang noch nicht richtig rund läuft, müssen wir abwarten, was im laufenden Betrieb noch so auftaucht.



Ich möchte mich bei euch allen für Eure Geduld bedanken und würde mich freuen, euch wieder an Bord begrüßen zu dürfen!



Ralf Drews

    Teilen

    Kommentare 2

    • super Leistung ! musste ich früher auch einmal machen ich weiß was für arbeit drin steckt , mein Respekt hast du (Y)